Marzipan Status logo Marzipan Status logo Marzipan Status

Subscribe to status updates via RSS feed.

Subscribe to status updates via Atom feed.

Copy and paste the command below into any Slack channel to start receiving live status updates.

Email Deliverability issues to BT Internet email addresses

Affected components

  • App - app.marzipan.co

Timeline

  • Resolved
    BT Internet and their anti-spam vendor have made updates to their systems and transactional emails should now be delivered to @btinternet.com email addresses.
  • Investigating
    We're waiting to hear back from the BT Internet postmaster.
  • Investigating
    We have intermittent deliverability issues with transactional email being sent to @btinternet.com email address. Our upstream service provider is looking into this.